PayPad 4G Service Degradation

Incident Report for Bumper

Resolved

Our partners have now resolved this incident. PayPad 4G connections are now restored.
Posted Aug 20, 2026 - 16:32 BST

Investigating

PayPads using a 4G connection are currently experiencing service degradation due to an issue with one of our partners. Please connect to Wi-Fi to continue taking payments.
Posted Aug 20, 2026 - 10:00 BST